Resultados 1 al 16 de 16

No me funciona bien el ME GUSTA de Facebook.

Esta es una discusión en el tema No me funciona bien el ME GUSTA de Facebook. dentro del foro vB4 Modificaciones, parte de la categoría vB4 Soporte General; A ver si alguien me puede dar una mano. Hice todo lo que dicen lo foros para el ME GUSTA de facebook. Ahora bien, lo presiono y me que da bien... pero al irme de la pagina y volver otra vez queda reseteado... como si nadie lo hubiera presionado... A ...



  1. #1
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado No me funciona bien el ME GUSTA de Facebook.

    A ver si alguien me puede dar una mano.

    Hice todo lo que dicen lo foros para el ME GUSTA de facebook. Ahora bien, lo presiono y me que da bien... pero al irme de la pagina y volver otra vez queda reseteado... como si nadie lo hubiera presionado...

    A alguien se le ocurre que puede ser?

    Les agradezco de ante mano.

    Saludos.

    Temas Similares:

  2. no me funciona el me gusta de facebook

    no me funciona el boton me gusta de facebook

    no funciona el me gusta de facebook

    no me funciona el me gusta en facebook

    facebook no me deja dar me gusta

    porque no funciona me gusta en facebook

    me gusta en facebook no funciona

    no funciona el like de facebook

    porque no puedo dar likes en facebook

    como funcionan los me gusta de facebook

    porque no funciona los like en facebook

    no puedo dar like en facebook

    no anda me gusta en facebookfacebook me gusta como funcionafacebook no me funciona bienno se activa el me gusta en facebookno me deja dar me gusta en facebookno me suma me gusta de mi facebookclick me gusta y no vano funciona el boton me gusta de facebookcomo funciona me gusta en facebookfacebook no me deja dar likes di muchosmegusta del facebook no me vael boton de facebook no suma me gustas a mi facebokpor que no me anda el me gusta del face
  3. #2
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    El codigo para el ME GUSTA de Facebook en vBulletin SIN vBSEO seria:

    Código HTML:
    <iframe src="http://www.facebook.com/plugins/like.php?href=$vboptions[homeurl]/showthread.php?t=$threadinfo[threadid]&amp;layout=standard&amp;show_faces=false&amp;width=450&amp;action=like&amp;colorscheme=light&amp;height=30" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:30px;" allowTransparency="true"></iframe>
    ahora, si tienes vbSEO se complica un poco ya que tienes que darle la direccion correcta (en formato amigable) sino lo detecta como otra pagina, lo que yo hize en una web fue poner:

    Código HTML:
    <iframe src="http://www.facebook.com/plugins/like.php?href=$show[vbseo_linkback_uri]&amp;layout=standard&amp;show_faces=false&amp;width=450&amp;action=like&amp;colorscheme=light&amp;height=30" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:30px;" allowTransparency="true"></iframe>
    con eso obtienes la URL de la pagina (vbSEO) sin el paginador, osea la página principal



  4. El siguiente usuario ha agradecido a Jhonnyf por este útil mensaje:

    DirectXp7 (30/11/2010)

  5. #3
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Gracias por tu pronta respuesta... Yo uso el 4.08 sin vbSEO.

    Le puse el codigo que vos pusiste en lugar de {vb:raw fblikebutton} y aparece pero cuano lo presiono me dice:

    A nnnnn le gusta esto. Ya no me gusta. ERROR y no me lo sube a mi facebook.


    Lo bueno es que si queda registrado si me voy y vuelvo a la pagina... Ja! pero no sirve para nada....



  6. #4
    Usuario
    Fecha de ingreso
    21/oct/2010
    Edad
    22
    Mensajes
    5
    Gracias
    0
    Agradecido 1 vez en 1 mensaje
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Se, bueno

    el facebook login connector es de vbulletin

    pero si usas nulled esto lo cataloga como error , creo que hay subfunciones .

    los mismos nulleadores dicen eso, que no es lo mismo, pero siempre hay solucion ..

    vere si la encuentro ..



  7. #5
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Cita Iniciado por zxleo Ver mensaje
    Se, bueno

    el facebook login connector es de vbulletin

    pero si usas nulled esto lo cataloga como error , creo que hay subfunciones .

    los mismos nulleadores dicen eso, que no es lo mismo, pero siempre hay solucion ..

    vere si la encuentro ..

    Gracias y espero novedades.



  8. #6
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Ya encontré tu error, cuando le pasas la URL en este formato:

    http://www.actors-studio.org/Foros/showthread.php?t=3118

    Facebook lo verifica y obtiene esta direccion:
    http://www.actors-studio.org/Foros/showthread.php?t=3118&s=69f1553bc13868c2f0f563

    es decir, se le agrega el session id en la URL, y es por eso que cuando le hace click en ME GUSTA, será una URL distinta y por tanto no se van a sumar

    ¿como eliminar eso de la URL?.... pues supuestamente activando las cookies.
    aqui el tema donde se habla de esa parte de la URL: Remove session id from URL - vBulletin.org Forum



  9. #7
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Cita Iniciado por Jhonnyf Ver mensaje
    Ya encontré tu error, cuando le pasas la URL en este formato:

    http://www.actors-studio.org/Foros/showthread.php?t=3118

    Facebook lo verifica y obtiene esta direccion:
    http://www.actors-studio.org/Foros/showthread.php?t=3118&s=69f1553bc13868c2f0f563

    es decir, se le agrega el session id en la URL, y es por eso que cuando le hace click en ME GUSTA, será una URL distinta y por tanto no se van a sumar

    ¿como eliminar eso de la URL?.... pues supuestamente activando las cookies.
    aqui el tema donde se habla de esa parte de la URL: Remove session id from URL - vBulletin.org Forum

    Pero las cookies las tengo activadas, mi ingles es bastante malo por eso uso las paginas en español... si me puede decir que probar... lo hago con mucho gusto....



  10. #8
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Bueno, lo encontre...

    en la plantilla

    facebook_likebutton

    Reemplazar el codigo por este:

    Código:
    <iframe id="fb_likeframe" src="http://www.facebook.com/plugins/like.php?href={vb:raw href}&amp;layout=button_count&amp;show_faces=false" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
    A disfrutar!!!!



  11. #9
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    ojo, creo que ya sé porque no te trabajaba bien, la respuesta que te dí era para vb3 y este es el foro de vb4.....



  12. #10
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Y????? cual seria tu solución... yo creo que asi, segun mi solución, esta funcionando... pero cual seria la tuya Jhonnyf?



  13. #11
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Cita Iniciado por Montecristo Ver mensaje
    Y????? cual seria tu solución... yo creo que asi, segun mi solución, esta funcionando... pero cual seria la tuya Jhonnyf?
    si, la tuya funciona porque es para vb4, mis respuestas fueron para la vb3,

    si te trabaja bien, entonces no hay problema



  14. #12
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    No, finalmente no me funciona... me dura una hora... o dos... y cuando vuelvo a entrar ya queda en cero otra vez... No tentiendo.



  15. #13
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Probemos algo mucho más agresivo.... edita /includes/init.php

    y busca esta linea (aprox 401)
    Código PHP:
    $show['search_engine'] = ($vbulletin->superglobal_size['_COOKIE'] == AND preg_match("#(google|msnbot|yahoo! slurp)#si"$_SERVER['HTTP_USER_AGENT'])); 
    y ahí agregale facebook, asi que debe terminar asi
    Código PHP:
    $show['search_engine'] = ($vbulletin->superglobal_size['_COOKIE'] == AND preg_match("#(facebook|google|msnbot|yahoo! slurp)#si"$_SERVER['HTTP_USER_AGENT'])); 



  16. El siguiente usuario ha agradecido a Jhonnyf por este útil mensaje:

    Duditas (31/10/2010)

  17. #14
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Cita Iniciado por Jhonnyf Ver mensaje
    Probemos algo mucho más agresivo.... edita /includes/init.php

    y busca esta linea (aprox 401)
    Código PHP:
    $show['search_engine'] = ($vbulletin->superglobal_size['_COOKIE'] == AND preg_match("#(google|msnbot|yahoo! slurp)#si"$_SERVER['HTTP_USER_AGENT'])); 
    y ahí agregale facebook, asi que debe terminar asi
    Código PHP:
    $show['search_engine'] = ($vbulletin->superglobal_size['_COOKIE'] == AND preg_match("#(facebook|google|msnbot|yahoo! slurp)#si"$_SERVER['HTTP_USER_AGENT'])); 
    Probando a ver que pasa... vamos a esperar unos dias y cuento!!!!!!!!!!!!

    Gracias Jhonnyf



  18. #15
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Estoy haciendo pruebas con el ME GUSTA de tu web y puedo ver que ya guarda la URL correctamente y sin agregarle el sessionid, asi que estoy seguro que esa es la solucion a tu problema

    Por otro lado ten en cuenta que cuando actualizes vBulletin, debes editar nuevamente ese archivo



  19. Los siguientes 2 usuarios han agradecido a Jhonnyf por este útil mensaje:

    Duditas (02/11/2010), Montecristo (01/11/2010)

  20. #16
    Usuario
    Fecha de ingreso
    21/nov/2009
    Edad
    41
    Mensajes
    45
    Gracias
    5
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: No me funciona bien el ME GUSTA de Facebook.

    Definitivamente Jhonnyf!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!! FUNCIONA!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Que decirte....? GRACIAS!



Etiquetas de este tema