Resultados 1 al 12 de 12

Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

Esta es una discusión en el tema Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12 dentro del foro vB4 Soporte General, parte de la categoría vBulletin; Hola a todos. Antes de preguntar nada e ir al grano, gracias por vuestra colaboración y ayuda. Se agradece. Me voy a presentar un poco para que no sea la cosa tan fría. Me llamo Jon y tengo montado un foro de reprogramaciones de coches (potenciaciones). Tuve phpBB, migre a ...



  1. #1
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Hola a todos.

    Antes de preguntar nada e ir al grano, gracias por vuestra colaboración y ayuda. Se agradece.

    Me voy a presentar un poco para que no sea la cosa tan fría. Me llamo Jon y tengo montado un foro de reprogramaciones de coches (potenciaciones). Tuve phpBB, migre a SMF y por ultimo, viendo que ninguno de estos sistemas de foro era lo suficientemente bueno, decidimos entre unos cuantos usuarios del foro, migrar a vBulletin.

    En este proceso he tenido unos cuantos problemas. Algunos de ellos los he ido solucionando, eran cosas de la configuracion en el panel de administracion. Pero hay otras que no soy capaz de hacer, como por ejemplo estas que os cito a continución:

    - En SMF las citas se generaban a traves de un BB Code diferente al que usa vBulletin. Entonces todas las citas salen mal, como si fueran texto normal y corriente, solo que con el BB Code de SMF por el medio. Se que se puede cambiar eso para que salgan correctamente, pero no se hacerlo. Un amigo hace mucho me dijo que a traves de consultas en la BBDD pero yo no tengo ni idea de como hacerlo.
    Os dejo un link de ejemplo, para que veais a que me refiero: Touran 140 BKD SOKI2001 - Página 17 . En el primer mensaje podeis ver a lo que me refiero.

    - Con la insercion de imagenes me pasa algo parecido. Tengo muchas fotos subidas por diversos usuarios que usaron imageshack y claro, no se que pasa que no se muestra la imagen y sale todo el BB Code como enlace. Podeis ver esto que me ocurre en este link: Audi A4 Avant B7 2.0TDI 140cv . Se puede ver en el primer mensaje como no se muestran las imagenes.

    - Otra cosa muy curiosa es que se me duplican los adjuntos. Los he importado con el Impex. He probado de todo (despues de buscar por google y reportamre a diferentes sitios) y no consigo que salgan correctamente los adjuntos. En alguna ocasion se repiten hasta 5 veces cuando solo tendria que salir una vez. Para que veais esto mejor: A3 1.9 TDI 105 CV EDC16 HW (VAG) 03G906021AB SW 1037391813 . En el primer mensaje ve ve como el mismo adjunto sale repetido muchas veces. No se que hacer para eliminar este error. Se da en multitud de sitios y claro, a mano me puedo eternizar. Lo he intentado pero es agotador.

    - El BB Code de insertar en linea los adjuntos es diferente al de SMF y me salen todos apelotonados abajo y el BB Code de SMF en medio del texto sin mostrarme las imagenes por ejemplo. No se como cambiar eso. Imagino que con una consulta en la BBDD. Ejemplo de ello teneis en el primer enlace que os dejo, que pone [attach=1] y no sale el adjunto asociado.

    - No me salen los avatares. En el SMF estaban en la carpeta de los adjuntos. En este se migran todos los adjuntos pero no salen los avatares. Esto me importa menos, pero bueno, si es algo sencillo perfecto tambien.

    - Al ingresar en el foro, la ventana que aparece diciendote que Bienvenido al foro y demas mostrando el nombre de usuario que inicia sesion, no sale bien. Pone la variable que utiliza el foro para generar el nombre.

    - Los videos que tenia del youtuve, que eran un monton, tampoco salen. Imagino que habra algun complemento para esto, aunque mucho em temo que no usaran el mismo BB Code y se quedaran igual aunque lo instale. Aqui podeis ver un ejemplo: http://prueba.chiptuner.es/showthrea...ir-en-el-coche .

    Muchisimas gracias a todos por vuestro interes. Llevo como unas 48 horas sin parar, delante del pc y no soy capaz de arreglar estas cosas. Solicite un ticket de esos pero yo y el ingles no somos muy amigos.... A ver si podeis ayudarme.

    Un saludo.

    Temas Similares:

  2. #2
    Usuario
    Fecha de ingreso
    31/oct/2010
    Ubicación
    España
    Mensajes
    204
    Gracias
    84
    Agradecido 91 veces en 68 mensajes
    Poder de Credibilidad
    5

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    A mí me supera todo esto, sólo te puedo decir cómo hacer que te salgan los avatares.

    Entra al panel de administración. A la izquierda, baja y busca donde pone Avatares y luego, clica en Tipo de almacenamiento para imágenes de perfil

    Imagen2.jpg

    Ahí especificas la ruta para llegar a la carpeta donde tienes los avatares en tu ftp


    En cuanto a lo que te ocurre al ingresar al foro con el nombre al dar la bienvenida a un usuario, a ver si se te refieres a esto
    Si te instalas la última versión del idioma español, también desaparece el error.


    Y por último te aconsejo que hagas un Mantenimiento y actualices todos los contadores. También, optimiza y repara tablas (1). A veces el resultado es sorprendente.



    (1) Está en el panel de administración, en la columna de la izquierda, más abajo que lo de los avatares.



  3. Los siguientes 2 usuarios han agradecido a Duditas por este útil mensaje:

    jmbb90 (13/04/2012), VBLUIS (23/04/2012)

  4. #3
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Hola.

    Ayer desesperado al final, borre todo y lo empece de nuevo.

    Ahora gracias al archivito cleaner.php he conseguido arreglar lo de las citas y lo de las etiquetas de las imagenes de servidores externos.

    El problema que se me presenta ahora es hacerle frente a la importacion de adjuntos. No tengo eggs de hacerlo. Le estoy poniendo las rutas ok y me dice todo el rato que Source file not found. Lo cachondo es que me muestraa los nombres de los adjuntos.

    Una cosa un tanto extraña.

    Lo de los avatares te lo agradezco. Esta vez no importe avatares, pase de importarlo, no habia muchos. Pero si rehago todo de nuevo le dare a importar.

    Voy a darle al tema de importar y a ver si consigo algo. Para despues ya meterme con el BB Code de los adjuntos.

    Un saludo.



  5. #4
    Usuario
    Fecha de ingreso
    31/oct/2010
    Ubicación
    España
    Mensajes
    204
    Gracias
    84
    Agradecido 91 veces en 68 mensajes
    Poder de Credibilidad
    5

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Siento no servirte de ayuda, yo tenía phpBB y cuando pasé a vBulletin lo hice desde 0. Sólo me limité a repetir los post-it

    En cuanto a lo usuarios, por la cuenta que les trajo, volvieron a registrarse rapidito y los post empezaron a subir enseguida.

    Te deseo mucha suerte!



  6. #5
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Gracias.

    Parece ir mejorando la cosa. Ahora ya solo me falta cambiar las etiquetas de los adjuntos en linea, que en SMF es [attach="numero de adjunto"] y en vBulletin es [ATTACH]"numero de adjunto"[/ATTACH].

    Imagino que con el cleaner.php o con una consulta a la BBDD se podria apañar.

    ¿Alguna idea?

    Un saludo y gracias .



  7. #6
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    prueba con eso:
    http://www.vbsoporte.com/f40/cambiar...e-dominio-598/

    es básicamente lo mismo y en tu caso vas a necesitar expresiones regulares (como un filtro de busqueda de archivo ??dd??.p?p) para cambiar eso



  8. Los siguientes 3 usuarios han agradecido a Jhonnyf por este útil mensaje:

    Duditas (17/04/2012), jmbb90 (17/04/2012), VBLUIS (23/04/2012)

  9. #7
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Hola Jhonyyf.

    El problema de los adjuntos es que muchos en la importacion desaparecieron y otros muchos salieron repetidos.

    Los que salieron bien no salen donde deberian y claro, todos los temas se ven con los adjuntos apilotonados abajo.

    Desde el area de soporte me dicen que es porque hay mismos adjuntos con ID´s diferentes y de ahi que se repitan, pero no me han dado solucion a lo de cambiar las etiquetas internas.

    Como podria hacer lo del numero de los adjuntos? Me explico. Cuando pones en el texto un adjunto pone el numero de referencia del mismo, no el numero de adjunto dentro del mensaje.

    Si subo 3 adjuntos no lo indica como adjunto 1, 2 y 3, si como como el numero que se les haya destinado en el servidor (ID). Tranquilamente podria ser 3125 el del primero y el resto sucesivos a este. Pero claro, ni idea de hacer eso.

    He ido solucionando cosillas con el cleaner.php, pero esta se me resiste porque no se como decirle lo que poner entre la etiqueta de los adjuntos.

    Un saludo.



  10. #8
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    pues ahi habria que analizar como guarda los adjuntos en SMF (formato, el codigo, etc, etc) y como lo ha importado vBulletin (su ID) y ver la relacion que existe para ponerle su ID correcto en los post.



  11. El siguiente usuario ha agradecido a Jhonnyf por este útil mensaje:

    jmbb90 (17/04/2012)

  12. #9
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Bufff, eso se escapa a mi control. jeje.

    Lo he mirado alguna vez y se que vBulletin crea carpetas numeras del 0-9 y dentro de estas mas carpetas de nuevo con las mismas numeraciones y va guardando los adjuntos.

    SMF los apilona todos seguidos y las da un numero natural, desde 1 hasta la cantidad total de adjuntos que haya. o eso me ha aprecido ver.

    Me temo que voy a tener que ir a mano de uno en uno.

    Un saludo y gracias por tu tiempo .



  13. #10
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Seguimos probando el nuevo foro y aparecen mas cositas.

    Un usuario me ha reportado otro fallo:

    - Los enlaces que dabas ants de redireccion, para amndar a usuario a otro tema del foro, al migrar a este desde smf todos te llevan a la primera pagina....

    Se puede hacer algo al respecto?

    Un saludo.



  14. #11
    Administrador Avatar de Jhonnyf
    Fecha de ingreso
    21/jun/2012
    Mensajes
    1.483
    Gracias
    2
    Agradecido N veces en N mensajes :)
    Poder de Credibilidad
    10

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    los ID de temas y demas de tu foro SMF al pasarse a vBulletin se graban de forma correlativa (1,2,3,4,....) pero a su vez en la tabla de temas, post, etc, etc hay un nuevo campo llamado "importXXXXXX" (forunid, threadid,etc)



  15. Los siguientes 2 usuarios han agradecido a Jhonnyf por este útil mensaje:

    jmbb90 (21/04/2012), VBLUIS (23/04/2012)

  16. #12
    Usuario
    Fecha de ingreso
    12/abr/2012
    Mensajes
    7
    Gracias
    7
    Agradecido 0 veces en 0 mensajes
    Poder de Credibilidad
    0

    Predeterminado Respuesta: Errores varios al migrar de SMF 2.0 a VBulletin 4.1.12

    Gracias.

    Entonces para solucionarlo que tendria que hacer? Porque entiendo lo que dices que pasa pero no se como solucionarlo.

    Me estan achuchando con los fallos y no doy a basto entre las imagenes adjuntadas, los archivos normales adjuntos y esto.

    Muchas gracias por tu ayuda.

    Un saludo.